This is the documentation for older versions of Odoo (formerly OpenERP).

See the new Odoo user documentation.

See the new Odoo technical documentation.

Интерфейс к Microsoft Outlook

Расширение Microsoft Outlook дает вам возможность выполнять ряд операций OpenERP непосредственно из клиентского ПО Outlook:

  • создать контакт или контрагента из сообщения электронной почты,

  • архивировать сообщения электронной почты и вложения в них в систему OpenERP,

  • отправлять любые файлы, вложенные в документы OpenERP (такие как предложения, проекты, и задания).

Может оказаться полезным отправлять документы о клиентском проекте в соответствующий проект в OpenERP, присоединяя документы к заказу (такие, как подтверждение платежа и подтверждения получения заказов), прикладывать документы к файлу сотрудника (например, резюме или уведомление о премировании по итогам года).

Совет

Версии Outlook

Расширение Microsoft Outlook работает с Microsoft Outlook 2003 и 2007, но не работает с Outlook Express.

Установка расширения Outlook

  • Шаг 1: установка расширения Outlook в OpenERP

Воспользуйтесь Мастером настройки OpenERP и установите приложение Управления отношениями с клиентами (Customer Relationship Management). В диалоговом окне Настройка приложения CRM (CRM Application Configuration) в разделе Расширения (Plug-In), выберите MS-Outlook. После этого запустится мастер Outlook Plug-In. Рядом с полем Outlook Plug-in, нажмите кнопку [Сохранить Как] (Save As) для сохранения расширения на вашем рабочем столе (или в любом ином расположении на вашем компьютере).

Вы также можете скачать руководство по установке, нажав на зеленую стрелку рядом с меткой Руководство по установке (Installation Manual).

Другой путь установки расширения Outlook -- это установка модуля outlook OpenERP. Когда вы установите этот модуль, запустится тот же самый Мастер настройки (Configuration Wizard), который был описан выше. Следуйте тем же инструкциям.

  • Шаг 2: Предварительные требования

1. Install Python 2.6+
или для 64-битной системы http://www.python.org/ftp/python/2.6.6/python-2.6.6.amd64.msi. Запустите файл для установки.

2. Python for Windows extensions - PyWin32, this module for python must be installed for the appropriate version of Python.

3. Specify the python folder in the system path (typically with this installer C:Python26)

Как задать path в Windows XP

Как задать path в Windows 7
Для изменения системных переменных окружения, совершите следующие шаги.

- From the Windows button, select Control Panel, then click System.
- Click Remote Settings to open the System Properties window.
- In the System Properties window, click the Advanced tab.
- In the Advanced section, click the Environment Variables button.
- Finally, in the Environment Variables window (as shown below) under System Variables, highlight the Path directory,
нажмите Edit и добавьте ;C:Python26.

4. If you are using MS Outlook 2007 than you are required to install "Microsoft Exchange Server MAPI Client and Collaboration
and Collaboration Data Objects 1.2.1 (CDO 1.21)" из
Совершите двойной щелчок на Exchange Cdo для его установки.

5. If you are using MS Outlook 2003, be sure to install the builtin Cdo component.
  • Шаг 3: установка расширения OpenERP в Outlook.

    1. Запустите двойным щелчком на исполнение файл OpenERP-Outlook-addin.exe, сохраненный на вашем рабочем столе. Подтвердите установки по умолчанию.

    2. Совершите двойной щелчок на файле Register plugin в директории OpenERP Outlook Addin (обычно в C:Program Files).

    3. Запустите Outlook.

Настройка расширения Outlook

Когда вы выполнили Шаги установки 1, 2 и 3, первое, что необходимо сделать -- это соединить Outlook с OpenERP. Необходимо произвести небольшую настройку.

Совет

Если вы хотите, чтобы соединение OpenERP было показано, как отдельная панель инструментов, перейдите в меню [Вид ‣ Панели инструментов] (View ‣ Toolbars). Выберите OpenERP.

  • Перейдите в меню [Инструменты] (Tools) и выберите [Настройка] (Configuration). При возникновении ошибки проверьте права доступа на данную поддиректорию.

Появится окно настройки, дающее вам возможность внести данные о вашем сервере OpenERP для настройки.

/doc_static/5.0/_images/outlook_menu2.png

Как соединиться с сервером

  1. На вкладке Установки конфигурации (Configuration Settings), в разделе Параметры соединения (Connection Parameters), нажмите кнопку [Изменить] (Change) и укажите параметры вашего сервера и порт XML-RPC, напр.: http://127.0.0.1:8069,

  2. Выберите базу данных, к которой вы хотите подключиться, и укажите имя пользовательской записи и пароль, требуемые для подключения к базе данных,

  3. Нажмите кнопку [Соединиться] (Connect).

  4. На вкладке Установки конфигурации (Configuration Settings) в разделе Параметры веб-сервера (Webserver Parameters), нажмите кнопку [Изменить] (Change) и внесите параметры вашего веб-сервера, напр.: http://localhost:8080,

  5. Нажмите кнопку [Открыть] (Open) для проверки соединения.

После установки успешного соединения вы можете захотеть настроить Outlook для соответствия вашим требованиям.

Для определения дополнительных типов документов, перейдите на вкладку Параметры Документов (Document Settings). Это место, где вы можете добавить объекты из OpenERP, которые вы хотите связывать с электронной почтой. Настройки по умолчанию дают некоторое количество предопределенных документов, таких, как Контрагенты (Partners), Зацепки (Leads) и Заказы на продажу (Sales Orders).

Ниже приведен пример, как настроить дополнительные типы документов. Предположим, вы хотите связывать почту со встречами.

  1. В Название (Title), укажите Встреча (Meeting),

  2. В Документ (Document), наберите имя объекта OpenERP, в данном примере crm.meeting,

  3. В Изображение (Image), выберите значок, который вы хотите использовать,

  4. Нажмите кнопку [Добавить] (Add) для создания описанного типа документа.

Примечание

Для поиска нужного объекта в OpenERP, воспользуйтесь меню [Администрирование ‣ Кастомизация ‣ Структура базы данных ‣ Объекты] (Administration ‣ Customization ‣ Database Structure ‣ Objects). OpenERP будет показывать только объекты, для которых установлены соответствующие Бизнес-Приложения / Модули (Business Applications / Modules). Вы можете добавлять в Outlook только те объекты, которые доступны в выбранной базе данных.

Использование расширения Outlook

Вы можете использовать меню [Инструменты] (Tools) несколькими способами.

Опция [Сохранить] (Push) позволяет вам архивировать сообщения электронной почты в OpenERP, либо в новые типы документов, либо в существующие. Она также позволяет вам создать новый контакт.

[Контрагент] (Partner) позволяет вам открыть Контрагента (Partner) в OpenERP, соответствующего электронной почте (т.е. адресу эл. почты) выбранного контакта.

При помощи [Документ] (Document), вы можете открыть соответствующий документ в OpenERP. Убедитесь, что вы подключились к веб-версии для использования данной функции.

  • Связь сообщения электронной почты с существующим документом в OpenERP

/doc_static/5.0/_images/outlook_config2.png

Как получить доступ к OpenERP из Outlook?

Для сохранения сообщений электронной почты в OpenERP из Outlook, выберите адрес электронной почты и нажмите кнопку Сохранить (Push). Альтернативно вы можете воспользоваться меню [Инструменты ‣ Сохранить] (Tools ‣ Push): откроется экран Сохранить в OpenERP (Push to OpenERP).

В разделе Ссылка на существующий документ (Link to an Existing Document), выберите объект, которому вы хотите добавить ваше сообщение электронной почты и его вложения. Вы можете выбрать любой объект, определенный вами в разделе Настройки документа (Document Settings), и присоединить выбранное сообщение электронной почты к выбранной записи. Расширение также позволяет вам выбрать несколько документов одновременно, путем выбора документа и нажатием клавиши <Ctrl> следующего документа.

Не забудьте нажать кнопку Поиск (Search) для обновления списка документов, когда вы выбираете различные типы документов.

  • Создание нового документа

Эта функция может быть использована для создания любого документа, настроенного во вкладке Настройки документов (Document Settings). Предположим, вы хотите создать новую зацепку из сообщения электронной почты. В разделе Создать новый документ (Create a New Document) выберите Зацепка CRM (CRM Lead), затем нажмите кнопку [Создать] (Create). Из выбранного сообщения электронной почты в OpenERP будет создана новая зацепка.

  • Создание нового Контакта / Контрагента

Если вы не можете найти контрагента или контакт для вашего сообщения электронной почты в OpenERP, расширение Outlook позволяет вам создать его «на лету» простым использованием содержащейся в сообщении электронной почты информации.

Выберите сообщение электронной почты, из которого вы хотите создать новый контакт, затем нажмите кнопку [Сохранить] (Push). В разделе Создать новый контакт (Create a New Contact), нажмите кнопку [Новый контакт] (New Contact). Эта опция дает две возможности: вы можете создать просто новый контакт (адрес), либо вы можете создать контрагента, с которым связан данный контакт.

  • Если вы хотите просто создать новый контакт, заполните информацию адреса в диалоговом окне и нажмите кнопку [Сохранить] (Save). При этом в OpenERP будет создана запись контакта.

  • Если вы также хотите создать нового контрагента, заполните контактные данные. Затем нажмите кнопку [Создать контрагента] (Create Partner), добавьте название контрагента, и нажмите кнопку [Сохранить] (Save).

  • Вы также можете добавить нового контакта к существующему контрагенту. Нажмите кнопку [Поиск] (Search) около поля Контрагент (Partner) и выберите соответствующего контрагента из списка. Затем заполните данные контакта и нажмите кнопку [Сохранить] (Save).

/doc_static/5.0/_images/outlook_creation.png

Создание контакта из Outlook «на лету»

  • Открытие созданного в OpenERP документа

Для доступа к архивным данным из любых документов OpenERP вы можете воспользоваться меню [Инструменты ‣ Документ] (Tools ‣ Document), которое позволяет вам получить доступ к документу в OpenERP непосредственно из вашей электронной почты.

Совет

Управление знаниями

Расширение Outlook совместимо с управлением знаниями (т.е. документами) OpenERP. Если вы установите приложение базы знаний, вы получите возможность:

  • производить поиск (search) содержимого документов вашей компании (тех, которые имеют типы .doc, .pdf, .sxw и .odt), а также архивированных сообщений электронной почты,

  • использовать файловую систему общего доступа, соединенную с различными документами OpenERP, для совместного доступа к информации и доступа из вашего браузера интернет,

  • организовывать и структурировать ваши документы (такие, как проекты, контрагенты, и пользователи)в системе OpenERP.

Примечание

Тестирование адаптера Outlook

Если вы установили адаптер Outlook, как описано, исследуйте его функционирование с базой данных, как описано в данном разделе.