This is the documentation for older versions of Odoo (formerly OpenERP).

See the new Odoo user documentation.

See the new Odoo technical documentation.

Интерфейс к Mozilla Thunderbird

Расширение Mozilla Thunderbird дает вам возможность выполнять ряд операций OpenERP непосредственно из Thunderbird:

  • создать контакт или контрагента из сообщения электронной почты,

  • архивировать сообщения электронной почты и вложения в них в систему OpenERP,

  • отправлять любые файлы, вложенные в документы OpenERP (такие как предложения, проекты, и задания).

Может оказаться полезным отправлять документы о клиентском проекте в соответствующий проект в OpenERP, присоединяя документы к заказу (такие, как подтверждение платежа и подтверждения получения заказов), прикладывать документы к файлу сотрудника (например, резюме или уведомление о премировании по итогам года).

Установка расширения Thunderbird

  • Шаг 1: установка расширения Thunderbird в OpenERP

Воспользуйтесь Мастером настройки OpenERP и установите приложение Управления отношениями с клиентами (Customer Relationship Management). В диалоговом окне Настройка приложения CRM (CRM Application Configuration) в разделе Расширения (Plug-In), выберите Thunderbird. После этого запустится мастер Thunderbird Plug-In. Рядом с полем Thunderbird Plug-in, нажмите кнопку [Сохранить Как] (Save As) для сохранения расширения на вашем рабочем столе (или в любом ином расположении на вашем компьютере).

Вы также можете скачать руководство по установке, нажав на оранжевую стрелку рядом с меткой Руководство по установке (Installation Manual).

Другой путь установки расширения Thunderbird -- это установка модуля thunderbird OpenERP. Когда вы установите этот модуль, запустится тот же самый Мастер настройки (Configuration Wizard), который был описан выше. Следуйте тем же инструкциям.

  • Шаг 2: установка расширения OpenERP в Thunderbird.

Чтобы это сделать, воспользуйтесь файлом openerp_plugin.xpi, который вы сохранили на вашем рабочем столе.

Затем действуйте следующим образом:

  1. В Thunderbird откройте меню [Инструменты ‣ Дополнения] (Tools ‣ Add-ons).

  2. Нажмите [Расширения] (Extensions), затем нажмите кнопку [Установить] (Install).

  3. Перейдите на ваш рабочий стол и выберите файл openerp_plugin.xpi. Нажмите [Открыть] (Open).

  4. Нажмите [Установить сейчас] (Install Now), затем перезапустите Thunderbird.

После установки расширения в меню вашего Thunderbird появится новый пункт [OpenERP].

Совет

Версия Thunderbird

Расширение OpenERP для Thunderbird работает с Thunderbird, начиная с версии 2.0.

Проверьте версию вашего Thunderbird перед началом установки, и скачайте последнюю версию, которая может вам понадобиться, с адреса: http://www.mozilla.org/products/thunderbird/

Настройка расширения Thunderbird

Когда вы выполнили Шаги установки 1 и 2, первое, что необходимо сделать -- это соединить Thunderbird с OpenERP. Необходимо произвести небольшую настройку.

Примечание

До начала настройки убедитесь, что у ваш сервер GTK и веб-сервер выполняются (протокол xml-rpc должен быть разрешен и доступен).

Перейдите в меню [OpenERP] и выберите [Конфигурация] (Configuration).

Появится окно настройки, дающее вам возможность внести данные о вашем сервере OpenERP для настройки.

/doc_static/5.0/_images/thunderbird_config.png

Как соединиться с сервером

  1. На вкладке Установки конфигурации (Configuration Settings), в разделе Параметры соединения (Connection Parameters), нажмите кнопку [Изменить] (Change) и укажите параметры вашего сервера и порт XML-RPC, напр.: http://127.0.0.1:8069,

  2. Выберите базу данных, к которой вы хотите подключиться, и укажите имя пользовательской записи и пароль, требуемые для подключения к базе данных,

  3. Нажмите кнопку [Соединиться] (Connect).

  4. На вкладке Установки конфигурации (Configuration Settings) в разделе Параметры веб-сервера (Webserver Parameters), нажмите кнопку [Изменить] (Change) и внесите параметры вашего веб-сервера, напр.: http://localhost:8080,

  5. Нажмите кнопку [Открыть] (Open) для проверки соединения.

После установки успешного соединения вам может потребоваться настроить Thunderbird в соответствии с вашими требованиям.

Для определения дополнительных типов документов, перейдите на вкладку Параметры Документов (Document Settings). Это место, где вы можете добавить объекты из OpenERP, которые вы хотите связывать с электронной почтой. Настройки по умолчанию дают некоторое количество предопределенных документов, таких, как Контрагенты (Partners), Зацепки (Leads) и Заказы на продажу (Sales Orders).

Ниже приведен пример, как настроить дополнительные типы документов. Предположим, вы хотите связывать почту с Заказами на закупки.

  1. В Название (Title), укажите Заказ на закупку (Purchase Order),

  2. В Документ (Document), наберите имя объекта OpenERP, в данном примере purchase.order,

  3. В Изображение (Image), выберите значок, который вы хотите использовать,

  4. Нажмите кнопку [Добавить] (Add) для создания описанного типа документа.

Примечание

Для поиска требуемого объекта в OpenERP, воспользуйтесь меню [Администрирование ‣ Кастомизация ‣ Структура базы данных ‣ Объекты] (Administration ‣ Customization ‣ Database Structure ‣ Objects). OpenERP будет показывать только объекты, для которых установлены соответствующие Бизнес-Приложения / Модули (Business Applications / Modules). Вы можете добавлять в Outlook только те объекты, которые доступны в выбранной базе данных.

/doc_static/5.0/_images/thunderbird_document.png

Как добавить дополнительные типы документов OpenERP в Thunderbird?

Использование расширения Thunderbird

Вы можете использовать меню [OpenERP] несколькими способами.

Опция [Сохранить] (Push) позволяет вам архивировать сообщения электронной почты в OpenERP, либо в новые типы документов, либо в существующие. Она также позволяет вам создать новый контакт.

[Контрагент] (Partner) позволяет вам открыть Контрагента (Partner) в OpenERP, соответствующего электронной почте (т.е. адресу эл. почты) выбранного контакта.

При помощи [Документ] (Document), вы можете открыть соответствующий документ в OpenERP. Вам надо подключиться к веб-версии для использования данной функции. Для использования этой функции вам необходимо открыть сообщение электронной почты.

  • Связь сообщения электронной почты с существующим документом в OpenERP

/doc_static/5.0/_images/thunderbird_selection.png

Как получить доступ к OpenERP из Thunderbird?

Для сохранения сообщений электронной почты в OpenERP из Thunderbird выберите адрес электронной почты и нажмите кнопку Сохранить (Push). Альтернативно вы можете воспользоваться меню [OpenERP ‣ Сохранить] (OpenERP ‣ Push): откроется экран Сохранить в OpenERP (Push to OpenERP).

В разделе Ссылка на существующий документ (Link to an Existing Document), выберите объект, которому вы хотите добавить ваше сообщение электронной почты и его вложения. Вы можете выбрать любой объект, определенный вами в разделе Настройки документа (Document Settings), и присоединить выбранное сообщение электронной почты к выбранной записи. Расширение также позволяет вам выбрать несколько документов одновременно, путем выбора документа и нажатием клавиши <Ctrl> следующего документа.

Не забудьте нажать кнопку Поиск (Search) для обновления списка документов, когда вы выбираете различные типы документов.

  • Создание нового документа

Эта функция может быть использована для создания любого документа, настроенного во вкладке Настройки документов (Document Settings). Предположим, вы хотите создать новую зацепку из сообщения электронной почты. В разделе Создать новый документ (Create a New Document) выберите Зацепка CRM (CRM Lead), затем нажмите кнопку [Создать] (Create). Из выбранного сообщения электронной почты в OpenERP будет создана новая зацепка.

  • Создание нового Контакта / Контрагента

Если вы не можете найти контрагента или контакт для вашего сообщения электронной почты в OpenERP, расширение Thunderbird позволяет вам создать его «на лету» простым использованием содержащейся в сообщении электронной почты информации.

Выберите сообщение электронной почты, из которого вы хотите создать новый контакт, затем нажмите кнопку [Сохранить] (Push). В разделе Создать новый контакт (Create a New Contact), нажмите кнопку [Новый контакт] (New Contact). Эта опция дает две возможности: вы можете создать просто новый контакт (адрес), либо вы можете создать контрагента, с которым связан данный контакт.

  • Если вы хотите просто создать новый контакт, заполните информацию адреса в диалоговом окне и нажмите кнопку [Сохранить] (Save). При этом в OpenERP будет создана запись контакта.

  • Если вы также хотите создать нового контрагента, заполните контактные данные. Затем нажмите кнопку [Создать контрагента] (Create Partner), добавьте название контрагента, и нажмите кнопку [Сохранить] (Save).

  • Вы также можете добавить нового контакта к существующему контрагенту. Нажмите кнопку [Поиск] (Search) около поля Контрагент (Partner) и выберите соответствующего контрагента из списка. Затем заполните данные контакта и нажмите кнопку [Сохранить] (Save).

/doc_static/5.0/_images/thunderbird_creation.png

Создание контакта из Thunderbird «на лету»

  • Открытие созданного в OpenERP документа

Для доступа к архивным данным из любых документов OpenERP вы можете использовать меню [OpenERP ‣ Документ] (OpenERP ‣ Document), которое позволяет вам получить доступ к документу в OpenERP непосредственно из вашей электронной почты.

Совет

Управление знаниями

Расширение Thunderbird совместимо с управлением знаниями (т.е. документами) OpenERP. Если вы установите приложение базы знаний, вы получите возможность:

  • производить поиск (search) содержимого документов вашей компании (тех, которые имеют типы .doc, .pdf, .sxw и .odt), а также архивированных сообщений электронной почты,

  • использовать файловую систему общего доступа, соединенную с различными документами OpenERP, для совместного доступа к информации и доступа из вашего браузера интернет,

  • организовывать и структурировать ваши документы (такие, как проекты, контрагенты, и пользователи)в системе OpenERP.

Примечание

Тестирование расширения Thunderbird

Если вы установили расширение Thunderbird, как описано, исследуйте его функционирование с установленной вами базой данных, в соответствии с инструкциями настоящего раздела.